FC2ブログ
2019 09123456789101112131415161718192021222324252627282930312019 11
ここでは今となってはレガシーなDSi以前のコンソールに関連したHomebrewの研究をしていました。 初めての方は正面玄関(ホーム)よりお入りになり「館内の歩き方」をご覧下さい。
No. 224

DS工房のYSMenu対応カードを追加

今回はYSMenuがセットアップできるカードを二つ追加しました。
追加したのはR4iRTSとiTouchDSです。
これと同じ事は既にレポートで遣っていますが、
DS工房に組み込んだので簡単に行えるようになりました。

また、M3系のカードでソフト・リセットが効かなかったので改修しました。
この現象自体は以前から気が付いていたのですが、
原因が分からずに放置していました。
一応、改修しましたがパッチで対応しているので、
使用するバージョンによってはソフト・リセットが効かない事も有り得ます。

今回は将来的な仕様の変更を見込んで他にも幾つかの改修を行いました。
詳細は工房支援室で確認して頂くとしてもう一つだけ紹介しておきます。
地味な変更ですがメニューのキャッシュ機能を追加しました。
比較的に非力なマシンではそれなりに効果が有るかも知れません。

尚、今回の更新は普段とは手順が異なるので注意してください。
通常の更新はDS工房フォルダをドラッグ&ドロップで上書き更新ですが、
今回はその前に下記のファイルを削除してから行います。
・DS工房/DS_menu.bat
・DS工房/resource/m3patch.dat
[No. 224] 2011/10/01(土) NDS-DS工房 comment(41)
コメント

ネジ3本

じょにーさん

シールの下にネジが有ったのですか…。
てっきり嵌め込みだと思い抉じ開けようとしました。(-_-)
BVgeUSCM by: アーク * 2011/10/25 10:40 * URL [ 編集] | UP↑

補足ですが、EDGEはシールを剥がしてネジ3本外すだけです。
簡単に殻を外せると思います。
- by: じょにー * 2011/10/25 10:14 * URL [ 編集] | UP↑

りんさん

おはようございます。

> EDGEのfake… 1.41へのファームアップ。。
> こんなのがいつのまにかあったんですね。。
一年ほど前から出ていたと思います。

> ファームアップしていないものでも最近のAKAIOは使用できないんですね…
一発屋ですからね…。コレクション入りが早いです。
BVgeUSCM by: アーク * 2011/10/13 09:19 * URL [ 編集] | UP↑

こんばんは

アークさん

EDGEのfake… 1.41へのファームアップ。。
こんなのがいつのまにかあったんですね。。

いつものように興味本位で出来るかどうか試しにファームアップしたところ
今まで使えてたAKAIO1.5が使用できなくなってしまいました。。
もちろんYSMenuまでも…

ファームアップしていないものでも最近のAKAIOは使用できないんですね…
どうしたんでしょうか??
r2W5us32 by: りん * 2011/10/12 21:31 * URL [ 編集] | UP↑

じょにーさん

こんばんは。

> ちなみにEDGEの殻を外してみると、…
成功しましたか…。
私は亀裂を入れてしまったので途中で止めました。

> …Cycloに化けるとかないでしょうかね?
EDGEはCycloの劣化クローンと思われるので無理かと…。
逆は可能かも知れませんが…。

一応、EDGEでYSMenuの起動を確認しましたが、
ROMを起動させるのは私には無理というものです。
BVgeUSCM by: アーク * 2011/10/12 20:12 * URL [ 編集] | UP↑

挨拶を忘れていました、すみません(汗
お久しぶりです^^
起動だけでもセーブデータのバックアップ/リストア機能が使えるので便利なのですが、やはりEDGEはOSの更新が遅いので起動出来ないROMも結構あるんです。YSmenuでROM起動できればなと思った次第です。
ちなみにEDGEの殻を外してみると、ICの足が半田でショートされている箇所が1箇所あります。例えばこのショートを取り除くとCycloに化けるとかないでしょうかね?
検証していただけないでしょうか?

- by: じょにー * 2011/10/12 10:06 * URL [ 編集] | UP↑

EDGE

じょにーさん、お久しぶりです。
…で良いですよね。

EDGEですか…。
起動だけならできるでしょうが、
ROMの起動までは難しいでしょうね。
BVgeUSCM by: アーク * 2011/10/11 23:03 * URL [ 編集] | UP↑

EDGEでもYSmenuを使える様に出来ないでしょうか?
- by: じょにー * 2011/10/11 09:22 * URL [ 編集] | UP↑

Re:お疲れ様でした

りんさん、塚さん。

おはようございます。

お蔭様で解決しました。
未だ仕様変更絡みで細かなバグが潜んでいますが、
今回のに比べれば大きな問題ではありません。
これで漸く先に進めます。

> PS でもこれからは手持ちの物でしか遊べ無いんですよね。
状況は月を追う毎に悪化しているように思えます。
業界全体が冷え込まなければ良いのですが…。
BVgeUSCM by: アーク * 2011/10/07 09:32 * URL [ 編集] | UP↑

お疲れ様でした

アークさん
DS工房 怒涛の更新お疲れ様でした

後はEZ5が入れば・・・完成かも
そのうちまた余裕(時間的にも気持ちの上でも)
が出来た時に期待しています。

PS でもこれからは手持ちの物でしか遊べ無いんですよね。
iqhSIKS2 by: 塚さん * 2011/10/07 05:12 * URL [ 編集] | UP↑

お疲れ様でした

アークさん

安定してよかったです。

これで皆同じ状況下で使用できます。

これからもYSMenuの使用できるカードを
増やしてもらえるとありがたいです。

更新本当にお疲れ様でした。
r2W5us32 by: りん * 2011/10/06 22:23 * URL [ 編集] | UP↑

漸くです

塚さん、りんさん。

ありがとうございました。

漸く安定しました。
今回の問題解決が長引いたのは移転先ばかり気にして、
移転元の事が飛んでいたのが大きな理由でした。

> ところで、r4dldi.datのCRC値は674DDD16で
> アークさんに教えていただいた3EDEF9DAにはなりません。
それで問題ありません。
先日は私のところも異常な状況でした。
BVgeUSCM by: アーク * 2011/10/06 21:29 * URL [ 編集] | UP↑

りんさんへ

>ところで、r4dldi.datのCRC値は674DDD16で
>アークさんに教えていただいた3EDEF9DAにはなりません。
>このままでよいのでしょうか?
ですが私のところでも同じように674DDD16になりました、
更新1005-2版(r3.8c)だとそうなるのかも知れません

只今「初期導入キット(1006版)」を確認しました
明日の朝までに再度いちから試してみたいと思います。
iqhSIKS2 by: 塚さん * 2011/10/06 20:48 * URL [ 編集] | UP↑

こんばんは

アークさん

いつもお早い更新ありがとうございます。

先ほど確認しました。
r4dldi.datのCRC値もかわることなくいけてます。

ところで、r4dldi.datのCRC値は674DDD16で
アークさんに教えていただいた3EDEF9DAにはなりません。
このままでよいのでしょうか?

M3系ではROM起動まで確認したので
差し支えはないのですが‥
r2W5us32 by: りん * 2011/10/06 18:15 * URL [ 編集] | UP↑

M3系

アークさん
おはようございます
更新 ありがとうございました
おかげさまで無事M3iまでROMの起動確認しました
iqhSIKS2 by: 塚さん * 2011/10/06 04:36 * URL [ 編集] | UP↑

りんさん

こんばんは。

> M3系のYSMenu作成後にA5DBA1DDに変更になる仕様
大分良くなりましたが未だのようですね。
初期構築への分離が上手く行ってませんね。
BVgeUSCM by: アーク * 2011/10/05 21:11 * URL [ 編集] | UP↑

こんばんは

>アークさん

更新ありがとうございます。
M3系上手くいきました。

今後も宜しくお願いします。

ところで、r4dldi.datは初期設定後以前よりご報告申し上げた
CRC値が674DDD16ですが、M3系のYSMenu作成後にA5DBA1DDに変更になる仕様になったのですね‥
r2W5us32 by: りん * 2011/10/05 16:27 * URL [ 編集] | UP↑

M3系

りんさん、塚さん

今日は朝から隣県へ出かけていましたのでこの時間になってしまいました。

お二人の報告内容が気になっていたので初期導入キットから構築し直しました。
先日も初期導入キットから構築し直したばかりですが、
セットアップ・ウィザード方式を導入する前でしたので…。

既に問題が有りそうな箇所の特定はできていますが、
お二人の症状が完全一致していない事からも他の要因も考えられる為、
更なる調査をしています。

セットアップ・ウィザード方式を導入する前は、
M3系のカードを最初に使用する時に同様の処理が行われていたので、
今より原因の特定が困難な状況でした。
それを排除して同じ環境を構築する事が新方式導入の目的ですので、
より確実な動作をするように改修します。
BVgeUSCM by: アーク * 2011/10/04 19:40 * URL [ 編集] | UP↑

DSFkit20111003

DSFkit20111003にて一から作成しました

>r4dldi.datのCRCが3EDEF9DAでm3dldi.datが0EB3ED1B、
>m3r4.dldiがA385837Eになっていますか?
については問題なく作成されましたが
R4iRTSについては問題なくROMまで起動しましたが
iTouchDSだと何故か _system_ファイルが作成されません。
iqhSIKS2 by: 塚さん * 2011/10/04 04:29 * URL [ 編集] | UP↑

その後も

アークさん

その後もいろいろと試しております。ない知識を搾り出し。。
r4dldi.dat
m3r4.dldi
のCRC値の違うものが何故できるのか?

初期導入10.3版も使用し再度作り直しても
どうも同じなんですよね‥

r4dldi.datだけ作成するため
毒抜きのTTMenu.dat,r4tf.dldi,ttextract.exeのみで作成しても
r4dldi.datのCRCは674DDD16のもののようです。
いよいよお手上げ状態です。

ところで、m3r4.dldiは自動作成されますが
どのファイルを使用して作成されてくるのでしょうか?
差支えなければお教え願えないでしょうか?
r2W5us32 by: りん * 2011/10/03 23:34 * URL [ 編集] | UP↑

塚さん

DSFkit20111003を積みました。
最新の更新が反映されていますので、
こちらで試して頂けますか。
BVgeUSCM by: アーク * 2011/10/03 18:46 * URL [ 編集] | UP↑

DSFkit20110925

DSFkit20110925で一から作成したところ
続いて初期設定の画面で
「C:DS工房¥TmpF¥r4patch.datが見つかりませんでした」
と表示され止ってしまいます。

どこかおかしいところでもあるのかな?
iqhSIKS2 by: 塚さん * 2011/10/03 17:58 * URL [ 編集] | UP↑

最後まで

アークさん
遅くまでありがとうございました。

M3系3種とも起動まで確認しました。
ありがとうございます

>やはりdldiが異なるのが原因かと…。
今回の10.2バージョンアップ前のCRC値です
m3r4.dldi:DD4144FD でご報告したものと同じです。
再度確認しました。やはり変わらないようです。それで起動はできていました。

ただ
m3dldi.dat:E46B6999
r4dldi.dat:8D955994
でした。
この環境下でこれまではいけてたようです。。
r2W5us32 by: りん * 2011/10/02 23:16 * URL [ 編集] | UP↑

Re:恐れ入ります

> m3r4.dldiではなくm3dldi.datが保管室に‥
失礼しました。
m3r4.dldiを積みました。

> M3iまでYSMenuが使用できなくなるのは…
やはりdldiが異なるのが原因かと…。
BVgeUSCM by: アーク * 2011/10/02 22:43 * URL [ 編集] | UP↑

恐れ入ります

アークさん
なにからなにまで。。申し訳ございません。。

m3r4.dldiではなくm3dldi.datが保管室に‥

私の環境はXPです。違うコンピュータでも同じでした。

今回のアップで
M3iまでYSMenuが使用できなくなるのは
なにかあるのでしょうか?
r2W5us32 by: りん * 2011/10/02 22:01 * URL [ 編集] | UP↑

Re:初期設定

同じファイルから同じファイルが生成されないとは思えません。
何かが変ですね。
マシン環境が関係有るとは思えませんが、
管理人の環境はWindows 7の64bitです。

最後の手段ですが当方のr4dldi.datとm3r4.dldiを保管室に積みました。
これで如何でしょうか?
BVgeUSCM by: アーク * 2011/10/02 21:46 * URL [ 編集] | UP↑

初期設定

アークさん

やはりなかなか上手くいかないみたいです。
余分なものがある為なんでしょうか?

すみませんいつもお付き合いいただいて。

また時あらためて、違うコンピュータで検証してみたいと思います。
ありがとうございました。
r2W5us32 by: りん * 2011/10/02 20:25 * URL [ 編集] | UP↑

Re:うーん

dldiファイルは中のコメントを変えている事が有るので、
同じにならない事も有ります。
初期設定後も上手く行きませんか?
BVgeUSCM by: アーク * 2011/10/02 20:16 * URL [ 編集] | UP↑

うーん

アークさん

>まさかとは思いますがr4v2.dldiはr4tf.dldiにリネームして有りますよね…
はい。リネームしています。

r4v2.dldiも同じように配置しています。r4v2.dldiは配置しなくてもよいのでしょうか?
r2W5us32 by: りん * 2011/10/02 20:01 * URL [ 編集] | UP↑

Re:早速調べてみました。

う~ん、現象がちぐはぐですね。
まさかとは思いますがr4v2.dldiはr4tf.dldiにリネームして有りますよね…。
BVgeUSCM by: アーク * 2011/10/02 19:43 * URL [ 編集] | UP↑

早速調べてみました。

アークさん

何回か初期設定してみました。

r4dldi.dat:674DDD16
m3r4.dldi:DD4144FD
とでますね。。これが問題のようですね。

m3dldi.datは同じCRC値でした。

作成時にどのファイルが問題なんでしょうか?

9.25の初期導入キッドから作り直したほうがよいのでしょうか?
r2W5us32 by: りん * 2011/10/02 19:34 * URL [ 編集] | UP↑

りんさん

> 念のためCRC値をr4v2.dldiのCRC値:487F9E66
> TTMENU.DATのCRC値:C9C43D38 です。
間違い無いです。

因みに初期設定後にr4dldi.datとm3dldi.dat、m3r4.dldiが生成されるのですが、
r4dldi.datのCRCが3EDEF9DAでm3dldi.datが0EB3ED1B、
m3r4.dldiがA385837Eになっていますか?

もし、違うようなら先ほどのファイルとこれ等のファイルも削除して、
もう一度初期設定を遣り直して見てください。
BVgeUSCM by: アーク * 2011/10/02 18:41 * URL [ 編集] | UP↑

いつもありがとうございます

アークさん

r4v2.dldi、TTMENU.DATも再度確認しました。
念のためCRC値をr4v2.dldiのCRC値:487F9E66
TTMENU.DATのCRC値:C9C43D38 です。

DS工房初期化のため上記2つのファイルを削除
_ds_ws.iniを差し替えて初期設定しました。

やはり同じ結果でした。
なかなかうまくいかないものです。。

塚さん、お久しぶりです。
M3iではいかがですか?
うまくいきましたか?

今回のバージョンアップ前のDS工房ではM3iは上手く起動してたんですがね‥
r2W5us32 by: りん * 2011/10/02 15:46 * URL [ 編集] | UP↑

残念ながら

残念ながら 我が家にはM3(それもJapanese)しかないので
確認できません。
iqhSIKS2 by: 塚さん * 2011/10/02 15:21 * URL [ 編集] | UP↑

M3系

りんさん、こんにちは。

M3系のセットアップが上手く行かないのは、
恐らく初期の構築が完全に行われていないものと思われます。
DS工房/resource/TTMENU.DATは公式v1.17を毒抜きしたものでしょうか?
DS工房/dlditool/DLDI/r4tf.dldiはr4v2.dldiでしょうか?
これ等を確認した上で再度初期設定を行ってください。

その方法は、DS工房/resource/m3dldi.datと、
DS工房/dlditool/DLDI/m3r4.dldiを削除して、
DS工房/Batch/_ds_ws.iniを初期導入キット0925版のものに入れ替え、
DS工房を起動します。
BVgeUSCM by: アーク * 2011/10/02 13:13 * URL [ 編集] | UP↑

おはようございます

アークさん

早速の対応ありがとうございます。

出力フォルダに問題なくファイルが作成されるようになりました。

ただM3系すべてですが
ROM起動にてdldi対応していないとでます。
報告しておきます。
r2W5us32 by: りん * 2011/10/02 09:55 * URL [ 編集] | UP↑

凍結解除

10/1版の問題が解決しましたので凍結を解除しました。
リビジョン表示も間違っていましたので、
10/2版として積み直しました。

りんさん、早々の試用報告ありがとうございました。
BVgeUSCM by: アーク * 2011/10/02 08:47 * URL [ 編集] | UP↑

りんさん

ありがとうございます。

こちらでも現象を確認しました。
9/25版の後、数日を掛けて改修してきたのですが、
昨日までの分は問題ないので本日行った改修が原因のようです。
判明するまで今回の更新は凍結します。
BVgeUSCM by: アーク * 2011/10/01 23:41 * URL [ 編集] | UP↑

ありがとうございます

アークさん

私もTTカーネルのバージョンが気になりいろいろ変えてみた結果です。

v118ですが
問題が発生したため、sucnvdose.exe を終了します
なるコメントは出現しませんが
(R4iRTSでの検証ですが)systemフォルダには何も作成されていませんでした。
v118_Rev162 も同じ結果でした。

コンピュータを変更しても同じでした‥

しかし我が家だけなんだろうか??


検証の追記
TTMenu_v117a12_J使用
R4iRTSとiTouchDSともに
問題が発生したため、sucnvdose.exe を終了します が出現します
ファイルは作成され、起動までいきますがROM起動にてdldi対応していないとでます。
v118_Rev162使用
R4iRTSとiTouchDSともに
問題が発生したため、sucnvdose.exe を終了します が出現しません。
ですが、ROM起動にてdldi対応していないとでます。

またいろいろ試してみたいと思います。。
r2W5us32 by: りん * 2011/10/01 22:03 * URL [ 編集] | UP↑

りんさん

こんばんは。

> 何が一番の問題なのでしょうか?
断定はできませんが、
恐らく使用するTTカーネルのバージョンだと思います。
M3系カードへのYSMenuの対応はパッチですので、
全てに対応できるわけではありません。
最近の非公式は枝分かれしてどれが主流かも分かりません。
実際、本当にカーネルが更新されているのかも疑わしいです。

一応、当方で確認できたのは以下のものです。
v117_JP_Patch_end(公式最終版を毒抜きしたもの)
v117a13_rev70_J
v118_Rev162
Ver118_Rev185-Evo
BVgeUSCM by: アーク * 2011/10/01 21:16 * URL [ 編集] | UP↑

こんばんは

アークさん、いつも更新ありがとうございます。

早速、我が家の環境下にて検証してみました。
追加のR4iRTSとiTouchDSとも同じ現象がでます。

『ローダを抽出の後』のコメントの後に
問題が発生したため、sucnvdose.exe を終了します
が何度となく出現します。。

キャンセルを何回かした後
r4dldi.dat及びr4patch.datがありませんとのコメントでした。

勿論出力フォルダのファイルでは起動しませんでした。

ファイルのチェックは問題ないようです。

何が一番の問題なのでしょうか?

わがところのコンピューターは何かおこりますから‥(笑)
r2W5us32 by: りん * 2011/10/01 21:06 * URL [ 編集] | UP↑

コメントの投稿
質問の前にこちらをお読み下さい。→質問時のご注意














管理者にだけ表示を許可する


| ホーム |
Page Top↑